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APPLICATION
NOTE

High-Speed CO, Ramping Technique
Rapid A/C; Curves in Minutes

The CIRAS-3's ability to rapidly control CO, gas concentration while simultaneously and continuously recording data by

utilizing the multi-level response scripts available in every CIRAS-3 has been available for some time. New interest in a

linear ramp of CO, concentration prompted PP Systems to update the PC-based Script Editor-streamlining the process to

create the response script file needed to create linear ramp response curves where the CO, reference level is changed at

each recording interval.

This application note describes the simple steps needed to create the script file, set up the CIRAS-3, run a linear ramp

experiment, and record data. Data are plotted to illustrate the linear ramp capability, followed by a description of the

post processing of the data to generate A vs. C; curves from the ramped gas exchange data. NOTE: Version 2.00 or later of

the CIRAS-3 PC Utility Program is required to utilize the ramp features described in this application note.

Script File Generation

1. Start the CIRAS-3 PC Utility Program: (Start > All Programs > PP Systems > CIRAS-3 Utility).

2. Choose File > Open Scripts Folder. Choose a location where the response scripts are saved.
The default location is User\MyDocuments\PP Systems\Ciras3_PC_Utility 2.XX\Response.

3. When the script editor window opens, select Gas Exchange - CO, Ramp from the
Application dropdown menu and choose your ramping script. NOTE: One ramping script
for C; leaves and one for C, leaves are available from PP Systems. The two scripts differ
primarily in the lower maximum CO, level reached for C, photosynthesis. Both may be

edited by the user.

4. Edit CO, Start, CO, End, Ramp (min),
and other experimental parameters in
any of the white text boxes. NOTE: Any
changes will automatically update and
the grid will be recomputed based on
the new parameters.

5. NOTE: The "1" in the Record Interval
column indicates that one data point
is recorded for each recording interval,
or one data point every 1.6 seconds.

6. Select File > Save As to save the new
response script. NOTE: If using V2.00
the filename must include the word
"ramp" to allow future editing in the
Ramp Editor. It is not required in later
versions of the program.
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Gas Exchange - CO2 Ramp

Application

Script File

Number of Levels 225
Records/Level 1

Environmental Controls
Approximate Reference Air
CO2 Start [100

(umel mel-1) (umel mel-1)

Temperature 25 ]
(°c) o

Gas Exchange - CO2 Ramp P vl
[ ci ca ramp 7]

Record Interval 1.6 (s)

€02 End [1500 |

Acclimation [120 Its) Ramp [6 | (min)

Slope 233.33 {ppm/min)

Fixed % of Reference
H20 |50
(%)
Light Intensity 51500 ]
{umol m-2 5-1) )

RGBW Red [3g | Green[37 |  Bluelzs | White 'b—‘i

(%)

Temperature Control Type per CIRAS-3, E Total Time to Complete Script: Oh 8m 0s
Level | Acclimation |Records | Record ln;amﬁ coz H20 Temp PAR RGBW Lo
1 120 1 1 = 100 50 25 1500 38-37-25-0

2 1 i 1 106 50 25 1500 38-37-25-0

3 1 1 1 112 50 25 1500 38-37-25-0
4 1 1 1 119 50 25 1500 38-37-25-0

5 1 1 1 125 50 25 1500 38-37-25-0
6 1 1 1 131 50 25 1500 38-37-25-0

T 1 i 1 137 50 25 1500 38-37-25-0 v
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Once the script file is created in the PC Utility package, follow these steps to prepare the CIRAS-3 for a linear ramp process.

1. NOTE: Be sure the \CIRAS3\Response directory structure
is in place on your USB drive and that you insert your drive
in the USB 2 port.

To transfer the script file from the PC to the CIRAS-3: Navigate
to Operations > Rec Options > Edit Rsp Crv > Transfer.
Follow the prompts to import the script file into Internal
Memory Files.

2. Perform a Stored Diff Bal Calibration to allow the CIRAS-3
to have accurate offset information applied continuously
throughout the linear ramp: Navigate to Operations >
Calibration > Stored Diff Bal and follow the prompts.
Set the CO, min and CO, max to match the ramp min and
max concentrations. The H,O range can be left at the
default of 0 to 100% or reduced to a smaller range closer
to the H,0O operating point of the response script. Select
Start and the CIRAS-3 will step through 6 levels between
the min and max settings, performing a diff-balance
at each level. It then computes a regression analysis
of the resulting offsets that will be applied for every
CO, concentration in real time. The Stored Diff Balance
Calibration takes 20-30 minutes and must be allowed to
continue to completion. Under Settings make sure Zero,
Diff Bal Mode is set to Auto Zero, Stored Diff Bal.

3. Start the experiment: The first ramp recording creates
the baseline trace to characterize the time response
of the system and stores the data for subsequent post
processing. Set the appropriate operational settings
similar to the start of the ramp on the closed and empty (no
leaf) PLC3 Universal Leaf Cuvette. Navigate to Operations
> Rec Options. Select Response Curves in the top
line to enable the Response Curve Scripts dropdown
menu. Select the correct response script for the linear
ramp. Select either internal or external storage (USB flash
drive) for the results data files. Select Start to begin the
experiment. Select Back to return to the data or graph
screen to watch the ramp script occur. Red triangles are
shown on the graph at each recorded data point (at this
recording interval, the red triangles overlap).

4. Start the experiment with a leaf: Repeat step 3, except
with a leaf in the PLC3 Universal Cuvette chamber.

NOTE: If the current environment of the leaf to be tested
differs greatly from the first step in the ramping script, it

is recommended to allow the leaf to equilibrate to those
cuvette conditions prior to starting the ramping script with
the leaf. If one watches the plot of A vs. time for the ramp
with the leaf, it becomes clear when CO, saturation occurs,
at which time the ramp can be terminated by selecting
End Recording.

. Transfer data files to PC and begin post processing: If

data files were stored to the internal memory, use the
Operations > Rec Options > Transfer Data screen to move
the files to a USB flash drive.

. Post Processing: The CIRAS-3's Stored Diff Balance

capability makes post processing very simple - all done

in Excel by adding just 3 new columns to the standard
CIRAS-3 output file. To begin, open the file for the empty
cuvette ramp in Excel. Copy the column of assimilation
rates (A), which is column Y. Open the ramp file with the
leaf in the cuvette, and paste the empty cuvette A rates
into an empty column. Subtract the empty cuvette A rates
from the rates obtained with the leaf in the cuvette. The
differences are the actual assimilation rates, starting after a
brief lag period (typically at about line 20).

. Compute C: The sub-stomatal CO, concentration, G, is now

recomputed using the new actual Assimilation and the
other values that have not changed (CO, analysis, and g
and E.):

[(0-5) % Cou]-A

G (umolmol™) =
(g+5)

Where g, is the total conductance to CO, transfer:

2] L %0
g.(mmolm? s )—[(1_585xr5)+(1.37xrb)J x10

[1.585 is the diffusion ratio of CO, and water in air, and 1.37
is the diffusion ratio of CO, and water in the boundary layer.]

An Excel spreadsheet is available from PP Systems to use
as a template for this calculation.

. Plot A vs. G, starting at about line 20, after the linear

ramp stabilizes.
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ColumnY from no-leaf data file copied here|

Actual A=ramp A (Col Y) - empty A |

C; recomputed
using actual A
H % @ = rammp soy 2.xdsy - Excel 7 @ I O %
h HOME ~ INSERT ~ PAGELAYOUT  FORMULAS  DATA  REVIEW  VIEW  DEVELOPER  TEAM Andyintz + |
A2 ~ Jr || =r2-m2 v v
X ¥ L AA AB AC AD AE AF AG AH Al Al AK AL~
i Adaxial Tsensor  Tcontrol Lcontrol PLC  Status .emptyA actual A actual Ci | |
2| 156 42 54 077 035 50 IR ) LED U -1.4| 5.6] 76.2532
3 | 156 4.2 54 0.77 0.35 50 IR LT LED u 1.3 5.5 76,7112
4 156 4.2 55 BiF7 835 50 IR LT LED U -1.3 5.5 76.8269
5 _ 1.56_ 4.2 5.5_ 0.77 0.35 50 IR LT LED U -1.3 55 76.8269 |
6 156 42 55 077 035 50 IR LT LED U -1.3 55 767692 o
Fi 1.54 41 54 0.76 0.35 50 IR LT LED U 1.2 5.3 779491 aCtUc;t|A
8 | 154 42 55 0.77 0.35 50 IR LT LED U -1.2 54 775618 (row AJ)
9 _ 156, 4.3 5.5 0.79 0.35 50 IR LT LED U -1 5.3 77.8491 VS
10 156 49 55 0.9 0.35 50 IR LT LED U -0.3 5.2 783028 actual Ci
11 _ 156 63 54 1.16 0.35 50 IR LT LED U 1.3 5 79.1585 (row AK)
12 | 156 7.9 54 1.45 0.35 50 IR LT LED U g 5 79.2104 Starting
13| 154 9.8 55/ 1.79/035 50 IR LT LED U 4.6 5.2 786162 | 3t row 20
14, 154 12 55 222 035 50 IR LT LED U 6.8 5.3 783267
15 _ 154 14 54 2.5_ 0.35 50 IR LT LED U 87 4.9 799149
16 1.54 16 5.4 292 0.35 50 IR LT LED U 10.5 5.4 77.8618
17 154, 18 55 371 035 50 IR LT LED u 12.3 5.2 79.2688
18| 154 19 55 35 035 50 IR ) LED U 13.9 5.2 79.8632
19 1.54 20 5.4 3.64 0.35 50 IR LT LED u 14.7 5.1 81.7139
20 154 21 54 3.84 0.35 50 IR LT LED u 15.8 5.1 833139
21 _ 152 22 5.5_ 3.96 0.35 50 IR LT LED U 16.3 5.3 B84.3845
22 152 22 55 407 035 50 IR LT LED U 171 5.1 87.0215
23 152 23 &b 4.18 0.35 50 IR LT LED U 17.2 5.6 86.7425
241 154 93 54 AT B35 B 50 IR {55 B LED 11 | 3 U i & 572 9N 3RRR JI=
Sheetl | Sheetz | Sheet3 | (3] [ [ 1 [¥

B ] -———+ 130%

Notes:

1

. The Stored Diff Balance Calibration should be performed after a 30-minute initial warmup prior to the beginning of
a day of testing. The Stored Diff Balance will remain stable throughout a full 8-12 hour day of testing and will not be
required again until the following day.

. The No Leaf (empty chamber) ramp [see step 3] is stable for 4 hours or more and does not need to be redone unless
experimental parameters are changed.
. We have not encountered a situation where humidity values or g, values change rapidly enough during the ramp to

cause substantial errors in gs and calculated C;. The scripts provided allow curves up to saturating A to be completed in
about 5 minutes, and g, changes with G are typically minimal during that time.

4. Ramp speeds up to 233 ppm per minute are acceptable.

. When executing multiple successive ramps, periodically perform a manual "zero" to keep the Auto-Zero function that

takes place every 30 minutes from interrupting your CO, ramp.
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Sample Results

A linear ramp response curve from 200 ppm to 600 ppm over 6 minutes was created with the Script Editor with a 300 ml/min
cuvette flow, a 100 ml/min analysis flow, and PAR set to1000 pmolmol?s™. The CIRAS-3 was warmed up and a Stored Diff
Balance Calibration was performed. The response script was run once with an empty chamber, and again with an ocimum
basilicum leaf in the PLC3 chamber.

200-600 ppm ramp with no leaf 200-600 ppm ramp with ocimum basilicum leaf

—— Oy noleaf ——C0ja COyd no leaf — O noleaf  ——C0.a C0.d no leaf

o 50 100 150 200 250 300 350 40073 o S0 100 150 200 250 300 350 400
Seconds Seconds

In the "no-leaf" case, the CO, differential is a relatively constant -14 ppm for most of the ramp, after starting out at 0 ppm
during the 120 second acclimation time when the CO,r is kept constant at 200 ppm. The -14 ppm CO,d represents the
response time of the system including cuvette mixing and gas transport back to the CIRAS-3 console, equivalent to 12.6

sec with these particular settings. Faster response time can be obtained with higher cuvette flow rate, however the
corresponding CO, differential will be lower. The CIRAS-3's ability to perform a Stored Diff Balance over the full range of the
ramp prior to running the response script eliminates the need to correct the reference and analysis for accumulated channel
difference.

With an active leaf in the PLC3, the CO.,d begins at -17 ppm during the 120 sec acclimation (instead of 0 as in the 'no-leaf"
case) because the leaf is actively assimilating. As the CO,r increases from 200 to 600, the CO,d increases from -16 ppm to -65

ppm at the end of the ramp.

A vs C, Comparisons

The Rapid A-G; curve technique and traditional point-by-point steady-state A-C; technique were compared on identical leaves
a few minutes apart. Data on both C; (soybean) and a C, (giant foxtail) were made and show very good agreement between
the two methods.
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Giant Foxtail at 25°C

30
25 - ®
hm @
. Comparison of High-Speed A/C; Ramping
. 20 (black points) to traditional point-by-point
i Steady-State (red points) for a typical C,
o Giant Foxtail leaf with PAR of 1500 pmol
E 5 m2s™ and Cuvette Flow of 300 ml/min.
g @ Rapid (7 minutes) Reference CO, was ramped from 50 to 500
=t @ Steady-State in 5 minutes (with one initial 2-minute
< 40 4 acclimation). Each Steady-State point had
a 2-minute acclimation time for total data
recording time of 18 minutes.
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Soybean at 25°C
30

25

Comparison of High-Speed A/C; Ramping
(black points) to traditional point-by-point 20 4
Steady-State (red points) for a typical C,
Soybean leaf with PAR of 1500 pmol

m2 s and Cuvette Flow of 300 ml/min.

A (umol m* s'w)

15
Reference CO, ramped from 100 to 1000 _ _
in 8 minutes (with one initial 2-minute & Rapid (10 minutes)
acclimation). Each Steady-State point had 0 @ Steady-State
a 2-minute acclimation time for total data
recording time of 22 minutes.
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If you would like to learn more about this application or speak with one of our experienced technical staff, u @pp_systems
please feel free to get in direct contact with us via any of the contact information listed below: m company/pp-systems

n ppsystems.intl
110 Haverhill Road, Suite 301 Tel: +1 978-834-0505 support@ppsystems.com n ppsystemsing

Amesbury, MA 01913 US.A. Fax: +1 978-834-0545 ppsystems.com 07.19
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